1

I've set a InspireView service using ArcGIS for INSPIRE 10.4. The INSPIRE theme is Administrative Units.

That service has its metadata. The two layers of the service have their own dataset metadata.

If I test it with the INSPIRE validator, it can't perform a GetMap request. I have done the request by hand and it works perfectly, so I don't understando what is happening.

Anyone can help me?

This is the Capabilities of the service: http://www.araba.eus/arcgis/rest/services/Geograma/AU/MapServer/exts/InspireView/service?REQUEST=GetCapabilities&SERVICE=WMS

This is the validator URL: http://inspire-geoportal.ec.europa.eu/validator2/

This is the error: "The Get Map request "" was not successful ("Could not retrieve an HTTP resource at url: "null" (Invalid layer bounding box)")"

1
  • The validation​ is for metadata nothing to do with a GetMap request
    – nmtoken
    Apr 7 '17 at 21:02
1

The INSPIRE Geoportal Metadata Validator validates metadata. A WMS GetMap request is not a metadata request, and therefore it is correct that if you paste a GetMap request into the text field provided by the form (http://inspire-geoportal.ec.europa.eu/validator2/), you will get an error.

You may paste the OGC Service Endpoint for your WMS service as:

http://www.araba.eus/arcgis/rest/services/Geograma/AU/MapServer/exts/InspireView/service?

which gives the following report:

http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-d031ae71-1dcc-11e7-a02d-52540023a883_20170410-110516/

and you can post the GetRecordById GET Request for your service as:

http://www.araba.eus/geonetwork/srv/spa/csw?SERVICE=CSW&VERSION=2.0.2&REQUEST=GetRecordById&ID=83bfeeac-b3fb-4f36-b3da-4c34711e1388&ElementSetName=full&outputSchema=csw:IsoRecord

which gives me the following report:

http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-eda7728e-1dcb-11e7-a02d-52540023a883_20170410-105856/

and you can post the OGC Service Endpoint for your CSW service as:

http://www.araba.eus/geonetwork/srv/spa/csw?

The report may take some time to come back depending on the number of metadata records you have in the catalogue...

0

The problem was the source data. I didn't project it correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.