5

I am using QGIS 2.18.4 Las Palmas on Windows 10 (32 bits).

I need to clip raster (TIF) 1 km resolution imagery files downloaded from MODIS using a shapefile mask of Argentina. To do so I tried to use the Clipper tool in the GDAL plugin. All of my layers are in the same coordinate reference system and I have the "Enable on the fly CRS transformation" option disabled.

After doing Raster >> Extraction >> Clipper >> Clipping mode: mask layer, I get the following error message:

Output driver 'AAIGrid' not recognised or does not support direct output file creation. The following format drivers are configured and support direct output: ...

followed by a list of 45 supported outputs.

After a thorough online search of related problems and potential solutions, I feel like I have exhausted all possibilities.

Could someone point me in the right direction please?

1

2 Answers 2

5

I've seen this problem too (on QGIS 2.18.3), although I don't seem to be able to reproduce it on-demand. Normally it defaults to GTiff, but sometimes decides it'll default to AAIGrid instead (maybe because it's first in the list alphabetically?)

It's fairly easy to work around, in the dialog you can click on the 'pencil' icon, and edit the command line.

Where you see

-of AAIGrid

replace this with

-of GTiff

(or whatever driver you want to use instead)

The dialog for clip calls gdalwarp, you can find the various options here

5
  • Problem solved.
    – Lucho
    Commented Apr 8, 2017 at 20:26
  • @Steven Kay : do you know if there is a ticket open about this problem ? This problem also occurs on v2.14.6 .
    – kaycee
    Commented Apr 18, 2017 at 16:24
  • @kaycee - I've not found one, I should have opened a ticket when I saw this behaviour :/ If you can reproduce this could you open a ticket?
    – Steven Kay
    Commented Apr 18, 2017 at 19:09
  • 1
    @StevenKay After further research, looks like a ticket has already been open regarding a similar issue: hub.qgis.org/issues/15285 . It has been resolved 2 months ago, so actual version of QGIS (2.18.6) should not have this problem anymore. I couldn't try it because I'm not having this issue actually.
    – kaycee
    Commented Apr 18, 2017 at 19:27
  • In my problem, it was -of XYZ which I changed to -of GTiff.
    – Sajjad
    Commented Jul 9, 2020 at 18:37
0

instead of setting a temporary file, you can select a file output (*.tif File). The parameter -of AAIGrid will be replaced then by the correct file type.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.