6

I have a Polygon Shapefile in a custom CRS which has feet as units. The Qgis Map is also set to the same CRS.

When I open the field Calculator, and enter $area, I see that the proper area is calculated: enter image description here

But when I save it in the Attribute table, some other value gets saved:

enter image description here

The ratio between the values seems to suggest that it is doing some conversion from sqFeet to SqMeters.

I was under the impression that the Field calculator would calculate areas in the units of Layer, but here it seems to be doing something else.

Instead of manually converting, is there a way to get QGIS to calculate areas in Layer's Units?

1 Answer 1

9

After reading this comment: How to read the area column in QGIS?

I found that there is a setting in Project>>Properties which you need to set. enter image description here

By default it is set to Sq Meters, and that is why Field Calculator was calculating area in Sq Meters, and not Sq feet as I expected. Once I set this property to Sq Feet, the calculation gave me the area in expected values.

1
  • Unfortunately this did not solve my problem, but I find it interesting that QGIS doesn't update those field based on your polygon crs you have defined. I had to use area($geometry). See this post
    – Binx
    Commented Apr 5, 2023 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.