1

This question already has an answer here:

I want to create buffer and set up distance in meters as units. The file is in WSG 84/UTM zone 18N. The project CRS is also set to WSG 84/UTM zone 18N. Units for distance measurement are set to meters (Project Properties/General settings) and Map tools preferred distance units are sets to meters. OTF is enabled. I use Fixed distance buffer tool and results are wrong it seems like a buffer is created in degrees not in meters. Is it a problem with a projection or the settings are wrong?

marked as duplicate by underdark qgis Apr 11 '17 at 17:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Can you attach an example of the wrong result? It seems that your configuration is correct. – mgri Apr 10 '17 at 19:09
  • 1
    Are you really sure, that you are using the proper CRS for the file? Have you checked with a background layer, if your geometries are where you want them to be? – AndreasK Apr 10 '17 at 19:17
  • I checked the CRS in QGIS and prj of the original file all showed WSG 84/UTM zone 18N (the one I should use ) but I tried your idea and checked it with background layer. Apparently the geometries weren't in the right place so I guess the problem lies in the file. Thanks for help – user95184 Apr 10 '17 at 22:55
  • @user95184 Did you try setting a large value for the buffer? – mgri Apr 10 '17 at 22:58
0

The buffer tool is set to metres - to six decimal places. I don't know of may situations where that accuracy is needed. Set your distance, in metres, to the left of the decimal point and try again.

  • The buffer tool is set to the units of the project (and not to meters as default). The six default decimals places are useful when dealing with Geographic Reference Systems; instead, they usually aren't used when dealing with meters as units. – mgri Apr 10 '17 at 22:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.