1

I have a shapefile that I have posted to geoserver using the REST api. I have set the coordinate system to EPSG:3785 as indicated below.

When looking at geoserver this is what I get when looking at the posted layer:

I'm wondering why the declared srs is not being populated here even though it is set on the shapefile and in the list in geoserver. I've tried several different projections that are in that list that do populate.

  • 4
    I think you want 3857 instead (3785 has been deprecated as far as I can recall...) – DPSSpatial Apr 10 '17 at 22:13
  • I've actually tried both 3857 and 3785, but neither of them come across in the declared SRS field – MasterN8 Apr 11 '17 at 14:19
1

My advice would be to either store your data in a local projected coordinate system or WGS84 (4326) then when you publish, let the Native SRS pick one of those up, then set the Declared SRS as WGS84 / 4326, and set SRS handling to ReProject Native to Declared.

There is no need to 'store' your data in web mercator - most web frameworks will utilize WGS84 quite nicely, and your desktop analysis will almost certainly be flawed using data stored in web mercator.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.