3

I'm using QGIS 2.18.3 in Linux Mint 18. I have downloaded Orfeo Toolbox and want to add it to the processing toolbox in QGIS. I have done it under Windows indicating the bin and lib path, but on Mint doesn't work. I read https://wiki.orfeo-toolbox.org/index.php/QGIS_access_to_OTB_applications but it doesn't seem logic that I have to build it from source just to do that. Anyone knows a easy/better way to do it?

  • I installed OTB from the regular ubuntugis-unstable repos and the tools appear in the QGIS processing toolbox. Nothing more to do...(I assume you have the qgis-providers package installed?). – Micha Apr 12 '17 at 18:45
  • No luck, I checked for qgis-providers package and ubuntugis-unstable, reinstall them, but nothing. Do you have to specify the paths in the Providers? I did that on Windows and worked fine. – Rodrigo E. Principe Apr 17 '17 at 13:11
  • I managed to install otb through the Package Manager of Mint, I an now able to use it from terminal. Now the path (checked) are /usr/bin and /usr/lib/otb/applications, I indicated the path in the processing toolbox settings, but nothing happened. – Rodrigo E. Principe Apr 19 '17 at 15:10
3

Ok, I am responding my own question because I have solved it for my own purpose. It doesn't mean that there could not be a better answer.

It seems to be due to the version. I downgrade to the LTR version of QGIS, and the Orfeo Toolbox appear in the processing toolbox!!

My steps where:

Remove packages

sudo apt-get remove qgis python-qgis 
sudo apt-get autoremove

Add PPA (add lines in etc/apt/sources.list)

# QGIS LTR
deb     http://qgis.org/ubuntugis-ltr xenial main
deb-src http://qgis.org/ubuntugis-ltr xenial main
deb     http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu xenial main

Update repository

sudo apt-get update

Install QGIS

sudo apt-get install qgis python-qgis qgis-plugin-grass

Before you run QGIS for the first time, delete (or rename) the folder home/user/.qgis2 where user is your linux user

That is it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.