3

I try to merge two polygon shapes in QGIS 2.18.4 with the MergeShapes plugin.

The error message shown below is what I get in return. Does anyone know a solution?

I want to make one table out of two with different fields. I want QGIS to put all different fields on a row, and combine the fields that are equal in both tables.

AttributeError: 'NoneType' object has no attribute 'isEmpty'

Traceback (most recent call last): File "C:/Users/rob/.qgis2/python/plugins\mergeshapes\mergeshapesdialog.py", line 87, in inputFile if files.isEmpty() or encoding is None: AttributeError: 'NoneType' object has no attribute 'isEmpty'

Python version: 2.7.5 (default, May 15 2013, 22:44:16) [MSC v.1500 64 bit (AMD64)] QGIS version: 2.18.4 Las Palmas, 59c1d21

  • 1
    Not sure about the plugin (perhaps you have non-geometric features) but have you tried the Merge vector layers tool from Vector > Data Management Tools > Merge vector layers? – Joseph Apr 12 '17 at 14:05
  • I just tried, but it´s not working either... It says: "global name 'dataobjects' is not defined See log for more details" – Rob Apr 12 '17 at 14:09
  • In MMQGIS - Combine I found another merge-option, but that also gives a python error... But thanks for the quick reaction! – Rob Apr 12 '17 at 14:30
  • No problem but you should probably examine your shapefiles to see if they contain any errors :) – Joseph Apr 12 '17 at 14:34
  • 1
    A simple but effective tool is Check validity from the Processing Toolbox =) – Joseph Apr 12 '17 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.