1

I have been searching through forums to solve this issue with no luck. I work for a housing finance agency specializing in affordable housing. When we receive applications, we send letters to announce the development to the district's elected officials. We have created a database (Access) to which I would like to link the geocode output and subsequently joined attributes.

I've built a model that takes the geocoded file and joins each feature class's (Districts) attributes to one output shapefile. The model then converts the output shapefile's attribute table to Excel. This Excel file is intended to link to the Access database which contains the names and addresses that correspond to each district/level of government. From Access, the letters are created.

The model works very well however, I cannot get Access to find the file because during the conversion from .dbf to Excel, the Table to Excel tool names the data sheet with the file name, which contains the file extension. For example, I can name the Excel file whatever I like, but the sheet tab will be alloutput.shp with no option to define the sheet name by the user.

I've attached a couple images to show the model and the output. Wondering if there is a workaround here.

Output Excel File

Model

  • Not the best method, but a workaround nevertheless: Have you tried creating a simple script for renaming the worksheet after it's created? You could create a .dll for such purpose and call it during runtime. – fabio.avigo Apr 13 '17 at 16:33
  • Table To Excel accepts a table view; you may insert Make Table View and use the Spatial Join output as input to Make Table View to control the naming of output for Table To Excel (using the Make Table View output name as input). – T. Wayne Whitley Apr 14 '17 at 0:14
  • Thank you for both suggestions. I had a chance to run the Make Table View tool in my model and it did exactly what I needed. My output data tab has replaced a "." with "_" which should do the trick. – cbedgeH2O Apr 17 '17 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.