I am completely new to GIS, and am trying to extract data from PRISM Climate data.

I used the Point Sampling Tool in QGIS, but faced the following error:

The new layer seems to be created, but is invalid. It won't be loaded

I have two layers:

  1. My raster layer is precipitation data from PRISM.
  2. My delimited text layer (.csv) has the following structure with a sample row:

    city        state   latitude     longitude      source
    marathon    texas   30.2066498  -103.2464676    Bing Maps

What could I be doing wrong here?

I previously tried sampling data from the same dataset (different time period), but with a different delimited text layer, and no such error occurred. Strangely, in my attempt to figure out this error, I tried it again and this error appeared.


Try to save the CSV file to a new shapefile before running point sampling tool. Also you need to make sure that both raster layer and shapefile layer (originally CSV file) have the same CRS (Projection). Point sampling tool does not work properly if the two layers have different projections.

| improve this answer | |

One possible cause of this error is that, as of version 0.4.1, the Point Sampling Tool defaults its output directory to QGIS's bin directory. If one forgets to browse to a different location there's therefore a reasonable chance of the plugin failing due to lack of write permission on the QGIS install. In this case the "seems to be created" bit in the message is spurious. The difficulty is that the output shapefile could not be created, not the shapefile was written to disk in some type of mangled format.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.