8

This question already has an answer here:

I've been trying to create a 400m buffer in a polygon layer in QGIS 2.18 and it seems like I may be doing something wrong compared to how the tool used to work.

Does the tool still use the units of the CRS?

When I try to create a 400m buffer or even a 10m buffer I end up just getting a large buffer that definitely isn't either one of those distances. I'm going to Vector->Geoprocessing Tools->Fixed Distance Buffer and setting things as follows in the screen shot. GeoJSON is in EPSG2768.


Seems like the buffer tool wasn't using the defined CRS units for my layers. Checked the output buffer layer and it was using WGS84 instead of EPSG2768. CRS for the project and all the layers was set to EPSG2768. Things didn't work until I changed the CRS for the buffer layer and then re-ran the buffer tool. I set up a couple virtual machines to test things out with mixed results. Fresh Xunbuntu VM with QGIS installed and the buffer tool worked right off the bat, but a fresh KDE Neon VM with QGIS had the same issue I initially posted about. Things are working now though.

bufferResult

marked as duplicate by mgri, underdark qgis Apr 18 '17 at 16:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Does your GeoJSON align with an Openstreetmap background by the QuickMapServices plugin? And what project CRS do you have? – AndreJ Apr 18 '17 at 11:38
11

Instead of doing your analysis through the "Fixed distance buffer" spatial analytic tool, try using the "Create Buffers" tool. I always use the "Create Buffers" tool for my buffering analysis in QGIS because I have tested it in many different projects and it always produces the results I need. To get to this tool: MMQGIS->Create->Create Buffers.

I find this tool very useful because you can buffer selected features. So after using the field calculator and selecting certain features by attributes then I can buffer only those selected features.

enter image description here

After you set your'Fixed Radius' to 400m, then you will get a result like below.

enter image description here

I've found that through all the updates that QGIS goes through that this "Create Buffers" tool seems to work the best.

  • This is the tool to use. General concept of using automatically "CRS units" in QGIS is outdated - often I have data coordinates and CRS in WGS84 (data is from gps, geojson-s, google APIs etc) , but distances, areas and buffers in degrees don't make any sense. These have to be in meters or kilometers, so such tools need clear way to give proper units without need to hack with dummy reprojections. These CRS change tricks does not work in global scale anyway. – JaakL Mar 20 '18 at 11:19
1

Check under Project> Project Properties if the Units for distance measurements option is correct.

1

Check the radius of the buffer with the meassure tool, if it is off by a multiple of 10, 100 or 1000 it will help you to establish wether your CRS mapunits are wrong. I have had this issue before where meters were kilometers in the Buffer tool.

Furthermore the meassure tool is also sometimes broken, reporting km when set to display meters... Furthermore the meassure tool is also sometimes broken

Not the answer you're looking for? Browse other questions tagged or ask your own question.