0

I am using ArcGIS Pro 1.4. I have a shapefile with the boundaries of the countries in Sub-Saharan Africa which I am using as the mask. The raster is a land use data set. When I run Extract by Mask I get a good clean raster except that there is a large rectangle out in the ocean. (Inside the red line)

Extract

What could be causing this?

1

It's hard to guess without knowing the bounds of both your input data and your mask data. To see if the problem's in your input data, change the symbology so sub-sarahan africa is all a single color (it may be hidden if values are 0 or NaN). Also change the 'Display NoData As' default from transparent to some color.

If you can't find make the rectangle appear, the problem's with your mask layer. Do the same inspection on that to verify.

Finally, check your extents and make sure there's nothing screwy there. (Geoprocessing > Env. Settings > Processing Extent)

  • Tired the tool again and I worked through those steps with no noticeable problems. Finally, I re-ran the tool for a third time and the box was gone. I'm not sure what worked there but it is fixed. – SteveC Apr 20 '17 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.