1

I am having issues saving an existing project on ArcMap 10.3. After adding another layer to the project, whenever I try to save the project, the software crashes and asks if I would like to send an error report. I have reset my application data but the error still persists and all other projects have started behaving the same way.

  • 2
    Does it also crash when you use Save As or Save A Copy? You can also run MXD Doctor and see if it brings up any particular issues. Also, bumping your version to 10.4.1 may help as well. A full ArcGIS reinstall may also be advised. – Baltok Apr 19 '17 at 14:48
  • @Baltok I guess I will have to upgrade to version 10.4.1 first to see if the issue will be resolved after which I will know if an uninstalling the software is imminent. – Akinbowale Mark Akintayo Apr 19 '17 at 15:19
  • Try using File>Save As. I had a similar issue where it held a copy of the map for no reason at all and then collapsed. File>Save as solved the problem for me. – MDHald Apr 19 '17 at 17:13
  • @MDHald The crash error still persists even with this option! – Akinbowale Mark Akintayo Apr 21 '17 at 8:34
  • I had this problem, but it was because I was using a third party extension that has expired. Once I turned off the extension, everything was okay. – Wing Mar 28 '18 at 0:41
1

Look into your Computers ENvironment Path Variables and ensure that there is only 1 Python Path Variable. Sometimes multiple variables are added and it causes the software to crash.

You can delete the variable by navigating to Windows Explorer > Right-click Computer > Properties > Advanced System Settings > Environment Variables - keep a backup of the Value in a Word doc in case removing it causes other issues.

  • I have tried that but the error still persists. – Akinbowale Mark Akintayo Apr 19 '17 at 15:19
  • 1
    Does this crash behavior persistent with other MXD's or is it just this one? – NULL.Dude Apr 19 '17 at 15:21
  • It is with all the MXDs, even when I open a blank project, added just a shapefile and tried to save the project, it didn't save the project. – Akinbowale Mark Akintayo Apr 19 '17 at 15:36
  • Try a repair Install if that does not work uninstall/reinstall may work. Time consuming but should work. Or call ESRI and create a case with them but they will tell you the same thing. – NULL.Dude Apr 19 '17 at 15:39
  • The software is currently running on a student version license. Having to reinstall it will create problems with the license I suppose and for this reason, I am scared to uninstall it. As for the repair, I have tried that but it didn't work. – Akinbowale Mark Akintayo Apr 19 '17 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.