I'm trying to manually move labels but having some trouble. I'm trying to move the labels while in edit mode. I've added fields for x coordinate (all null), y coordinate (all null), rotation (all =0), and font-size (all =10). This makes the "move label" and "rotate label" buttons active, but when I click on the labels, no box around the label appears and it's impossible to move the label. What am I doing wrong?

  • Are you using the labeling from labeling toolbar (NOT layer options - labels!)?
    – underdark
    Apr 18, 2012 at 17:57

2 Answers 2


We found recently the same behaviour occurs when layer's alias have special character like "à , é, ë.. etc". If this is your case, just rename layer to a simple name. I will create a new bug entry for this in hub.qgis.org.

  • I've tried your fix, but it's still not working. Any other ideas?
    – Jake
    Apr 19, 2012 at 23:56
  • I too would like to move some labels. Did you find a solution @Jake? Thanks.
    – Patty Jula
    Jun 2, 2012 at 0:30
  • @ Patty Jula:see my answer.
    – Shepherdjo
    Aug 16, 2012 at 6:30
  • 1
    Is the behavior already documented as a bug? Otherwise I can also do it, because I just had this problem with ä and ü and would love to have it fixed...
    – dassau
    Nov 22, 2012 at 11:31

I assume that, you have not set enough space (field width) for the coordinates of the label (these are real numbers). I think the moving is not possible because of this.I encountered the same problem once.

At any rate: This problem was solved in a current thread: How to add labels outside of features? The new plugin automatically sets enough width in the field for the coordinates. Moving should be possible then.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.