1

I can no longer search for tools, etc using the Search window in ArcMap i.e. Windows | Search doesn't work and nor does ctrl + f.

I thought updating my student license would do the trick but after doing so it's still the same. I have also tried to fix it by deleting Normal.mxt but that didn't work either.

I read somewhere that ArcMap can sometimes misbehave because of problems related to the pc user account.

I may accidentally have shut down my computer the wrong way last week and before I was properly logged off (by pulling the plug too early).

What could be the cause of this and how may I fix it?

My version of ArcMap is 10.5.0.6491.

  • 1
    What version of ArcGIS? Which search has disappeared - the Find button to find records in layers in your map, or the Search window to find tools and datasets? The Search Window can be re-added by Windows menu > Search – Midavalo Apr 22 '17 at 16:45
  • It sounds more like Find but it would be nice to be sure before spending time writing an answer. – PolyGeo Apr 22 '17 at 20:32
  • I have now updated the question. I'm asking about the search tool and no it can not be re-added from the Windows menu. – ArcCandle Apr 30 '17 at 9:42
  • 1
    Looks like a bug. Have you contacted ESRI's support? – BERA Nov 1 '17 at 12:39
  • 1
    Did you try the usual tech support approach of renaming your ESRI application data folder to see if that fixed it? It would be something like C:\Users\xxyourusernameherexxx\AppData\Roaming\ESRI? A less radical approach would be to just rename your Normal.mxt which would be in the subfolder \Desktop10.5\ArcMap\Templates. If that doesn't fix things you can rename them back to keep any customizations, and move on to other methods. Another similar tech support suggestion would be to rename your ESRI folder in the registry but messing with the registry may not be to your liking. – johns Nov 1 '17 at 13:21
3

I was having the same problem with Desktop ArcMap 10.6 on Windows 7. I tried the following:

  1. Remove normal.mxt from the c:\drive.

  2. Renamed the ESRI folder in the c:\drive (essentially the same as step 1, I know.)

  3. Deleted DefaultDomain_Path_folder from the c:\drive.

Option 3 worked for me!

I did not try to create a new user so can not comment on the efficacity of that option.

2

I have experienced the same problem since 2016.

I contacted ESRI and they sent me different types of possible solutions.

I tried the first solution they emailed me, that is by creating a new Windows user for the computer.

I created a new user and logged out from the current user. When I open ArcMap, the search windows finally appear and everything is functioning normally.

1
  • Create a new user in Windows and log in and Open Arcmap with the new user.

OR

  • Remove normal.mxt from this directory C:\Users\\AppData\Roaming\ESRI\Desktop10.5\ArcMap\Templates
  • Option 2 worked very well. For those of us that do not have Admin privileges to create a new user this is an easier solution. – Simon.y Aug 2 '18 at 17:03
0

I have recently encountered similar problem in ArcGIS 10.5. I applied many possible solutions including renaming 'CATID' folder. However, it didn't worked for me. Alternatively, I logged off to new user account and found 'Search Tool' working properly.

You may copy your data from existing user account, create new windows user account and delete the existing one (optionally). The Search tool would become alive by clicking 'Search tool' button in ArcGIS.

0

Review the user file inside the DefaultDomain_Path_ folder of this location :

C:\Users\username\AppData\Local\ESRI

When opened the file showed strange characters (I guess it got corrupted).

What I did was copy a user file from another account and copy it by deleting the corrupt file.

-1

I deleted DefaultDomain_Path_ folder from this location C:\Users\username\AppData\Local\ESRI and it worked for me.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.