2

I'm having a crash on startup that appears to've come from nowhere—I'd not used QGIS in a while and then tried to launch it and it crashed. This happened on both my work and home computers, so I suspect it's related to a system update (running MacOS 10.12.4); QGIS 2.18.2/2.14.3 (depending on computer) installed from KyngChaos along with python lib.

Here's the crash report I'm getting:

Process:               QGIS [1403]
Path:                  /Applications/QGIS.app/Contents/MacOS/QGIS
Identifier:            org.qgis.qgis2
Version:               2.18.2 (2.18.2 [exported])
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           QGIS [1403]
User ID:               502

Date/Time:             2017-04-24 11:01:35.517 +0100
OS Version:            Mac OS X 10.12.4 (16E195)
Report Version:        12
Anonymous UUID:        CE6880BA-8529-B952-7BBC-A72CAED27607


Time Awake Since Boot: 540 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes:       0x0000000000000001, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Illegal instruction: 4
Termination Reason:    Namespace SIGNAL, Code 0x4
Terminating Process:   exc handler [0]

Application Specific Information:
dyld: in dlopen()
BUG IN LIBTRACE: MH not found

What's going on here? How can I get QGIS to launch?

  • I don't know much about MacOS, but I suspect that a system update destroyed your QGIS installation`s dependencies. Can you re-install QGIS? – AndreJ Apr 24 '17 at 11:00
  • I can confirm a similar issue and it is related to the 10.12.4 update. A reinstall has NOT fixed it for me. – CitizenFish Apr 24 '17 at 11:20
  • I have the same issues already for a month. It is said on KingChaos, that: WARNING: QGIS will crash if Qt4 developer components are installed in the standard /Developer location. Either rename /Developer/Applications/Qt/Plugins or uninstall Qt before running QGIS. – Yurish Apr 24 '17 at 11:49
  • 1
    A reinstall didn't fix it, but fully removing QGIS and reinstalling did. – futuraprime Apr 24 '17 at 12:27
5

I had the same issue and removed QGIS by using free software "AppCleaner" from freemacsoft.net.

I then downloaded the last version from KingChaos (2.18.2-1) and installed step-by-step. Now, I have working QGIS!

I think, that the problem was with some plugins, that I had in old QGIS.

  • 1
    A couple re-installs didn't fix it, but merely dragging the QGIS.app into the trash and reinstalling the QGIS app worked for me. No wonder Kyngchaos's 0_README file recommends trashing previous installs. – Dave X May 9 '17 at 16:52
3

try to find and remove (or rename) phonon.so in pyqt stuffs installed inside OSGeo4Mac installation. The crash happen only after OSX upgrade to 10.12.4. Phonon is a not well maintained multimedia package in QT. Probably the error is not present with QGIS master (e.g. python3/QT5)

this is the result of the investigation done in Boundless Spatial by Larry Shaffer, please let us know if it fix the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.