33

I have been running ArcGIS 10.5 on my PC (Windows 10 Home) since December with no issues. This past week I have started to get ActiveX Security Warnings when I click into a parameter field in any ArcToolbox tool.

enter image description here

Windows Security Warning

An ActiveX control on this page might be unsafe to interact with other parts of the page. Do you want to allow this interaction?

It doesn't seem to matter whether I click Yes or No, I can still modify the field and the tool still functions fine.

Answering Yes:
enter image description here

Answering No:
enter image description here

I am working through the answers to Why do ArcToolbox tools give ActiveX error?, although there doesn't appear to be an actual answer on that Q&A. Additionally it's back in the Windows XP/7 days with IE 7/8, and I'm running Win 10 with IE 11 (although that's never used). If it matters, the browsers we use are Firefox 53.0 (64-bit) and Chrome 58.0.3029.81 (64-bit).

The issue I am having sounds different as it's happening only when I click on the parameter field - not when I open the tool or, as I read elsewhere, ArcMap. The warning messages on that Q&A also have different text so it may be a completely different problem.

I have opened Internet Explorer (for the first time since getting this PC!) and looked at the Local Zone settings and everything for ActiveX is marked Enabled, including one about running without prompting:

enter image description here

I have also Disabled another one "Automatic Prompting for ActiveX Controls" but that didn't stop the message appearing.

I went through the suggested ActiveX settings from Problem: Issues with ActiveX controls when launching ArcMap, updated all my settings to match (the only one I had to change was the "Automatic Prompting for ActiveX Controls" one I changed in my testing above).

No new software has been installed on my PC in the past week.

What could have caused this to start appearing, and how do I fix it?

  • I have this issue too, and I'm curious if the answer that you got solved your problem. I'm very cautious for changing something in the registry, so perhaps there is another solution for this. It's just an annoyance and appeared out of nowhere for me. – Mutumba Aug 9 '17 at 16:53
  • @Mutumba Yes the answer solved the problem for me. You will see the green check-mark next to the answer which indicates the answer was accepted by me as the solution. – Midavalo Aug 9 '17 at 17:12
  • Did this occur only when your system received the Windows 10 Creators Update (1703)? It came out in March/April (7 months ago, when your question was asked) - we are facing this same issue on 1703 only for both 10.5 and 10.5.1 in our organisation. – Mgamerz Dec 13 '17 at 18:51
  • @Mgamerz I imagine it possibly is related to that update. I know I would have updated my Windows whenever it was available, but don't recall if it was before or after I started getting these activex issues. Definitely something worth noting – Midavalo Dec 13 '17 at 19:11
  • I think there is a new WIndows update available, and also 10.6 beta, so it may be worth testing either/both of those to see if the issue still occurs. I'll take a look when I have a few hours to test – Midavalo Dec 13 '17 at 19:12
12

Quick and short solution:

Original Posting

I found a fix for this on ESRI's web site - axtiveX error warning. A staff member came into the thread and confirmed it is a bug in current versions of ArcGIS (at time of writing, 10.5.1 was the latest).

So far we have only seen it affect our 1703 users. Haven't tested on 1709, but I'm going to imagine it also affects them too. At my org we are not allowed to change security zone's as the other answer's states (policy for this setting is controlled far higher up the chain), but the link above has a workaround (or possibly actual fix?). I hear they are supposed to have this in 10.6.

Some of our users reported this issue to Esri Support a few weeks ago. We have reported this issue as a defect to our development teams. They are well aware and are investigating this issue at their end.

"BUG-000105427: ActiveX control warnings appear when interacting with geoprocessing tools after updating to Windows 10 version 1703 (Creators Update)".

They link to their knowledge base article on how to fix it: Bug: Internet Explorer script errors are generated when running any geoprocessing tool from ArcToolbox on some systems that implement folder redirection

Essentially you need to copy their .xsl files into your arctoolbox folder, which for 10.5 (by default) is located at C:\Program Files (x86)\ArcGIS\Desktop10.5\ArcToolbox\Stylesheets. While the link to this page shows an error that looks very different from the one you describe it seems to be the same issue, just an old version of internet explorer. I confirmed it was working for a few of our users.

  • The DWORD fix didn't work on my Surface Pro 3 with 10.5.1 and Windows 1709. This worked. I have had no issue with my workstation at least in recent memory. – johns Dec 19 '17 at 18:10
  • This worked for my ArcGIS 10.5.1 installation while the DWORD 1201=0 did not. – user918967 Dec 19 '17 at 22:51
  • For me, this is definitely preferable to messing with the registry. Thanks! – nmpeterson Jan 3 '18 at 22:22
  • ArcGIS Desktop 10.6 was released today so if you were able to reproduce this in an earlier version it would be great if you can verify whether 10.6 fixes it for you. – PolyGeo Jan 17 '18 at 23:43
  • It will be several weeks until my organization has approved 10.6 for use. – Mgamerz Jan 19 '18 at 0:50
14

I found a solution that worked for me.

I change setting in the register. Search for 1201 and value 0 (DWORD) at: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\0

Problem running any tool (on Esri's Geonet forums)

enter image description here

  • Welcome to GIS SE! Thank you, adding 1201 to my registry solved the issue. I certainly don't understand why though, even after reading the link you included in your answer. – Midavalo Apr 26 '17 at 23:31
  • Also, as a new user please take the tour to learn about our focused Q&A format. – Midavalo Apr 26 '17 at 23:31
  • 2
    Before making registry edits I like to know what I'm doing. Can you add something to your answer explaining how this works? Thanks! – PhilippNagel Jun 26 '17 at 15:20
  • 2
    This solution seems to work but is not well explained. I second the request to explain what the change to the registry is doing please. Also, for all who are a bit puzzled by how to follow the instructions above - using Win10, right click on windows logo and click 'run', enter 'regedit', this opens the registry. Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\0 and double click on 1201 setting the value data to 0. That should do the trick. – Kristina Aug 9 '17 at 14:39
  • 1
    In essence, this boils down to "automatically enable the initialization and scripting of unsafe ActiveX controls in the Internet zone for the current user". This is all spelled out in this article [blogs.technet.microsoft.com/fdcc/2011/11/03/…. – Erik Anderson Oct 11 '17 at 18:06
13

The one important difference that most suggestions omit, and very possibly this is all that's needed to fix this, is that in Zone 0 a new DWORD 1201 MUST be created if it doesn't already exist. In other words changing all the other DWORD values to "0" will not work unless 1201 is also added.

The solution can be found here: https://geonet.esri.com/ideas/13563-fix-activex-security-bug-for-toolbox-scripts

Add a "DWORD" entry called "1201" to the "HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\0" folder and set the value to 0. Restart ArcGIS for it to take effect.

I see that a few posts were deleted from here; one that correctly identifies the problem as a recent windows update which it was, the other which states that adding the DWORD solves the problem. Perhaps, leaving correcting these posts to sound more like answer and not deleting them would have been a better approach since the actual accepted answer here is incomplete.

  • 2
    I'm not sure I read any that suggested changing the others to 0, only the one that said you need the 1201. But I agree, if the 1201 isn't there you need to create it and the issue should go away (it did for me). +1 – Midavalo Sep 8 '17 at 15:38
  • the post by @Brandus. It's worded as a thank you post but the important clue is there "Adding new DWORD 1201 to my registry solved the annoying issue". – Jakub Sisak GeoGraphics Sep 11 '17 at 13:51
  • 1
    I tried changing ONLY DWORD 1201 to 0, and found it helped, but when I did a search of the toolbox and clicked the link in the search results tab that is intended to switch to the catalog tab and set focus to the tool, it was only switching to the tab - and not selecting the tool. I then change two DWORDs 2001 and 2004 from 3 to 0 and found that it behaved correctly. Now for the REALLY hard part: convincing security staff in a large organization that this registry change doesn't introduce a security vulnerability. +1 – Kirk Kuykendall Oct 14 '17 at 19:45
  • Kirk, those two keys are: 2001 -- .NET Framework-reliant components: Run components signed with Authenticode, and 2004 -- .NET Framework-reliant components: Run components not signed with Authenticode. I could see opening the Zone 0: 2001/0 value, but maybe Zone 0: 2004 should be a 1 for a user prompt rather than 0 to just run. – V Stuart Foote Oct 30 '17 at 19:09
1

After working with this most annoying bug on 10.5.1.7333, I finally installed 10.6 this morning. I am delighted to say that this bug is GONE in 10.6.0.8321!!

FWIW - the .xsl file replacement advice did not work for me at all.

Upgrading to 10.6 worked for me!

protected by Midavalo Dec 19 '17 at 16:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.