3

I was helping a patron find imagery in an area using ArcMap's World Imagery as a basemap, and found a troubling issue. We just needed low resolution imagery for locating study sites, as we were reloading the map often. However, on opening the context menu and attempting to remove layers from rendering, we were greeted with an error, "This type of layer cannot be turned off". Screenshots follow:

Table of Contents, showing layers of basemap Error

I've tried changing visual scale range, but that is impossible with the layer.

Is there any way to force the layers off or remove the high resolution imagery?

  • "I want an answer with decent backing. If there is no way to do this, give reasons, if there is, give guide" - A good question should include details of your own efforts. What has your own research told you so far? – Midavalo Apr 27 '17 at 23:38
  • 3
    If you want low res imagery, why not connect to ArcGIS Online from ArcMap and load in the Landsat imagery instead? – Simon Apr 28 '17 at 0:49
  • 1
    @Simon, that's an obvious solution I didn't think of, thanks! That should work for 70% of what I need this solution for, thanks! – coneypylon Apr 28 '17 at 3:52
1
+100

I was able to recreate your error. I found this answer that I agree with. It is one layer with multiple layers baked into it that cannot be turned off. ESRI simply offers them as visible so you can zoom to them individually. Here is some ESRI documentation backing that up. It's standard image caching. A way you can work around rendering performance in ArcMap is by setting the "Don't show layer when zoomed" options in the layer properties.

  • The workaround works, thanks! While it's not quite what I wanted, it does keep loading time down. – coneypylon Apr 28 '17 at 18:40
  • You can create bookmarks which may also increase performance. – gisdude Apr 28 '17 at 21:49
1

A few other answers have touched on why you cannot disable individual resolutions because they are cached. If slow performance is the main issue, I have a few ideas for speeding it up. One would be to set a visible scale range to the base map. First zoom to the map scale you want (probably as far out as you'd like to see) and then you right click on the base map and "visible scale range" you can then set your minimum scale. This makes it so the basemap will only draw when zoomed in a certain amount that you set.

Additionally, this thread on geonet goes over various things to try to speed up base map rendering, its a bit outdated but some of the solutions are still applicable. One solution that looks promising is :

Open ArcCatalogue on the sidebar of your ArcMap session. Select: Add ArcGIS server then enter the url for the basemap services: http://server.arcgisonline.com/ArcGIS/rest/services from there you can expand the menu to select the basemap you want to use and drag it into your ArcMap window. This should add the basemap to your session and render quicker.

Additionally, if you're working with projected data Arc has to work harder to convert their basemaps from WGS_1984_Web_Mercator_Auxiliary_Sphere projection to whatever your projection is in on the fly, which can slow down load times.

I would also recommend looking into updating your graphics card or drivers to check if they're up to date. A number of people on that thread have also had luck with changing their firewall and antivirus settings to allow exceptions to ArcGIS. Such as:

.arcgis.com
.arcgisonline.com
.amazonaws.com
.virtualearth.net (for Bing maps)
.esri.com

Here are some direct instructions from Esri about how to troubleshoot basemaps.

  • Unfortunately the visual scale range is not able to be set for this basemap layer, but I'll try the basemap services method at work tomorrow, thanks! – coneypylon Apr 28 '17 at 3:49
  • I think if you right click on "Basemap" or "World Imagery" it should work – GISKid Apr 28 '17 at 12:53
  • No, I think ESRI may have locked that directly out. The basemap services load much quicker, and I found the ESRI_Imagery_World_2D which is lower res and loads really quick, so thanks! – coneypylon Apr 28 '17 at 18:38
  • Weird, I could do it that way on my machine. Still kind of odd that they don't let you do it for each individual basemap though, glad you found a solution! – GISKid Apr 28 '17 at 20:37
0

Adding onto @gisdude's answer, make sure that you have "hardware acceleration" enabled to help in the drawing of the basemap. Also, you could even try and tick on "Enable continuous display updates during navigation" if you are using a remote desktop session to help your patron.enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.