6

I often transfer layers from Windows machine to Linux and vice versa and it causes me problems (incorrectly displayed labels and same with text in attribute table) when I use drag and drop to put vector layers in QGIS.

On linux there is System encoding set to UTF-8 while on Windows it is Windows-1250. Is it possible to change the setting of the Windows version of QGIS to be also set to UTF-8 by default?

Tried to google a solution but no success.

2

Go to the "Settings -> Options -> Data Sources" menu,
and look for the checkbox "Ignore shapefile encoding declaration",
when you uncheck it, the default encoding (for shapefiles) will be 'set to' UTF8.
This will actually prevent ogr's 'on the fly' conversion of shapefiles encoding.
See this thread for further details.

Data Sources Menu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.