0

I am able to download geoserver source code , build it with maven , create maven eclipse project but when i load the project from /src in the eclipse it does not run. after checking build path i found that M2_REPO structure is not as what the build path is expecting.

Here are my computer details on ubuntu 14.04

JAVA

java version "1.8.0_121" Java(TM) SE Runtime Environment (build 1.8.0_121-b13) Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)

maven

Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T22:11:47+05:30) Maven home: /usr/share/maven3 Java version: 1.8.0_121, vendor: Oracle Corporation Java home: /usr/lib/jvm/java-8-oracle/jre Default locale: en_US, platform encoding: UTF-8 OS name: "linux", version: "4.4.0-72-generic", arch: "amd64", family: "unix"enter image description here

enter image description here

Update

Tried to build the same thing with lower version (2.10) in windows it worked. Ununtu still does not work

4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.