2

I upgraded from QGIS 2.8.1 to 2.18.6 and all seems very nice.

One problem I have is with display. Some, though not all, of my line and point layers won't display unless I zoom in. All my polygon layers display at all scales.

The affected layers do not have Scale Dependent Visibility enabled for the layer. So I'm not sure why this behavior is occurring.

I'm having to zoom way in to see them -- so much so that it is not practical.

UPDATE: I've narrowed down the problem, but haven't found a solution. It's one of the layers. When I turn on labeling for that layer, all features in that layer suddenly disappear, and most (but not all) of my other vector layers also disappear. If I disable display of the offending layer, display of all other layers is restored. This issue does not occur with 2.8.1, but occurs consistently in 2.18.6.

  • Can you try to re-build Spatial Index on your affected layers? – Kazuhito Apr 27 '17 at 13:09
  • Tried Layer Properties > General > Coordinate reference system > Create spatial index. Unfortunately had no effect. – krock Apr 28 '17 at 14:06
  • Workaround discovered. If I create a new project with the same data I do not have this problem. It appears to be an artifact of opening in 2.18.6 a project created in 2.8.1. – krock Apr 28 '17 at 14:10
  • Did you create the new project from scratch? Or is it a copy created by Save As command in 2.18.6? Anyway, that's great! – Kazuhito Apr 28 '17 at 14:23
  • Saving As doesn't fix the problem. Creating a new project from scratch works. To speed up process, I grouped layers and then saved the group as a layer definition file. That QLR file can then be added to a new 2.18.6 project without the display problem. A relatively quick work around for the layers, but any project-specific properties would have to be recreated in the new project. – krock Apr 29 '17 at 19:01
1

I've encountered the same issue with Girona 3.0.3; even though I change the scale based visibility, it stays unchanged.

The workaround I used was to export the concerned layer and manually apply the same format from the old layer. This worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.