1

When I tried "zonal statistics" with QGIS, I encountered the following error.
ERROR 1: NUMPY driver was compiled against GDAL 2.1 but current library version is 1.11

I could find people who had same problem,

so, I updated QGIS 2.18.5 to the latest version. But I still have the problem.

Here's what I did.

  1. Uninstalled QGIS 2.18.5 by "sudo apt-get remove qgis"
  2. re-installed the latest version, that is, 2.18.7 as the follows.
    1. sudo apt-get update
    2. sudo apt-get -f install
    3. sudo apt-get install qgis python-qgis qgis-provider-grass

Re-installed QGIS says its version is "2.18.7". I think the above problem should have been solved already, but I got exactly the same error.

Any ideas ?

--- Update ---

It seems that "sudo apt-get qgis" loads gdal-1.11 even though gdal-2.1 is installed. How can I make it load gdal-2.1 ?

  • 1
    Which repository did you install qgis from? – user2856 Apr 29 '17 at 22:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.