I am having trouble getting .shp layers to "line up" on QGIS.

Now, I opened them both in ArcGIS and noted there that they had the same projection. I opened them up in a text editor, and just to be sure, copied the data from one .prj file into the other. Reopened them in Arc and had no problems whatsoever.

However in QGIS I can't get them to come into the same map. I've tried every combination of CRS / Layer menu options that I can think of, nothing seems to work.

They seem to have the same Projected Coordinate System, but different Geographic Coordinate Systems: this I assume from going to the full extent, and note that both layers are on the map but hundreds of KM apart.

I tried setting them to the same GCS in QGIS properties, but then they both vanished. ("Zoom to Layer didn't work, they were gone.)

Is there are process I should be following here?

If the data were corrupted, wouldn't duplicating the .prj data be enough to fix the problem? If it's a GCS issue, how do I change that?

Mostly I'm looking for a process I can apply every time I import data to QGIS so I'm guaranteed to work around any CRS issues.

  • What CRS are the Data in, and to what CRS (and data) should they align?
    – Matte
    Apr 30, 2017 at 16:37
  • When the data aligns one is in Geographic Coordinate System: GCS_GRS 1980(IUGG, 1980) and Lambert_Conformal_Conic PCS. The other is in NAD_1983_Oregon_Statewide_Lambert_Feet_Intl Lambert_Conformal_Conic GCS_North_American_1983. The data frame is set to export to the latter. This works fine in Arc. In QGIS I set them both to NAD_1983_HARN_StatePlane_Oregon_North_FIPS_3601 in their properties menu. . They show identical CRS data. In full extent they're on the same planet, just far apart. No amount of tweaking can bring them together. Apr 30, 2017 at 21:15

1 Answer 1


When you 'set' the CRS in QGIS you are only defining what the projection is, but are not actually reprojecting the data to it. Most GIS softwares will reproject on the fly so that layers look approximately the same even though they are not. When you only change the CRS definition it will then plot the shapefiles on the same 'place', but in drastically different places as the geometries are likely very different still.

It appears to me that you have jumbled your geometries by only redefining the CRS. So to fix that:

  • set the CRS back to their original projections

  • (and if using QGIS) after deciding which projection you want to work with, export a new reprojected version of the shapefile by clicking 'save as' and selecting the appropriate projection you want to reproject your shapefile to.

I see this happen quite often and that should sort it out.

  • Oh right! Save As! Completely forgot about that. Thanks Apr 30, 2017 at 22:30
  • It's one of those things that I find makes the qgis interface so much better than arcgis but an easy one to forget about when making the transition!
    – scabecks
    Apr 30, 2017 at 22:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.