1

Just upgraded from ArcGIS 10.3.1 to 10.5 and am now trying to run a spatial ETL tool from command line. I have ArcGIS and the Data Interoperability extension but I do not have stand-alone FME installed. I never had a version older than 10.3.1 on this computer. I get the error saying it can't be run outside of the ArcGIS environment described in the article below. We have concurrent use licensing. Should I follow the instructions in this article or does it only apply to much older versions? I can't quickly test this on my own due to restrictions on the computer, so I'd like to know if this is what I need to do in advance.

https://knowledge.safe.com/articles/474/fme-workbench-reports-that-it-cant-be-run-outside.html

  • 2
    Make a back up of those files to another location and delete them. Workbench should run. What version of FME are you using? – Mapperz May 1 '17 at 13:41
  • I have data interop for ArcGIS 10.5 - 2016.1.2.0 20160817 build 16661 WIN32. I'll go ahead and put my request in for an Admin to do this. Just hope it does't break it and I have to wait again for them to put the files back. – John May 1 '17 at 14:14
  • 1
    The problem was i needed to run the tool through arcpy and not directly to fme.exe. Once the extension is properly checked out in the py script the tools work. – John May 1 '17 at 17:18
2

Although the problem is the same - one of licensing - I'm not convinced the solution is the same as in that article. As you'll have noticed, the version numbers are way older than what you are using.

You aren't clear, but I suspect that you have both ArcGIS and FME installed on your computer? Is that right? Firstly, you have both the FME and Data-Interoperability tags on the question, but - more importantly - I think the issue is that you are running a Data Interop ETL tool but an FME license is being (wrongly) applied.

If that's the case, what version of FME is installed? I see there is a fix to help prevent this sort of thing from happening, and it was implemented in FME2016.0.1, so having that version might help.

But, the other issue is that you are running this from the command line. What command do you use? I wonder if the wrong executable is being picked up? eg ArcGIS was higher up than FME in the path variable, but you upgraded so it's now lower and FME is preferred? Maybe you need to check the path environment variable, or be more specific in your command as to what you are running.

If neither of those work, then yes, do try the license rename. It may help, and if you only do the rename it can't hurt. But, if that fails too I'd contact a support team. If it's Data Interoperability then contact Esri support. If it's FME then contact the Safe Software support.

  • I have ArcGIS and the Data Interop extension but I don't have stand-alone FME installed. The version is 2016.1.2.0, 20160817 build 16661 WIN32. – John May 1 '17 at 16:31
  • The command I am trying to run from a bat file is "C:\Program Files (x86)\Esri\Data Interoperability (x86)\fme.exe" "C:\Users\gfsf12725\AppData\Local\Safe Software\Interoperability\ArcCatalog-20170501-075328\fmetool-a08968_626296032_0.fmw" – John May 1 '17 at 16:33
  • Right - as you mentioned above - I don't think that's the command to use. That's running FME directly, and the licensing limitations are because of that. Anyway, glad to hear that it is working now. – Mark Ireland May 1 '17 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.