5

I just installed QGIS v2.18.2 for Mac and can no longer define a custom CRS. I get the following error. I've tried using the same parameters as existing CRS and still get the error.

Ive tried complete reinstall and restart but am still having this problem. Is there anything else I could try?

enter image description here

3
  • 1
    Does it help if you delete all Generated CRS?
    – AndreJ
    May 2, 2017 at 12:05
  • Yes!! Thank you so much. Sorry, it seems so obvious now May 2, 2017 at 16:07
  • from memory, i think the custom CRS entries with an empty 'parameters' list can cause problems..
    – Steven Kay
    May 2, 2017 at 17:37

1 Answer 1

5

You have three Generated CRS with an empty projection definition string.

I wonder how you got these (I never had such cases, but I did not use Amalthea GIS data in any way) and suggest to delete them.

Generated CRS are build whenever QGIS can not identify an EPSG code numer from a shapefile .prj file (and never removes any of them). Since you have not created those custom CRS yourself, you can always safely delete them if you run into problems, or lack overview in the custom CRS table.

1
  • i think they're the result of using really obscure / unsupported CRSes, I think I last saw this using some IAU2000 projections after a QGIS update (they were valid in a previous release, though - I had used them successfully for mapping)
    – Steven Kay
    May 3, 2017 at 12:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.