3

ArcMap 10 - Geodatabase with related tables & relationship classes.

I've written a script that parses data between two databases. When I go into the attribute table of the point feature class and select a record, I have the option to click the "Related Tables" button. When I use this button, the resulting table is either empty, or has only 1 record.

The original data has many related records, and they have been parsed correctly into separate feature classes. The records are ALL in the related table, but they're not able to link for some reason. The relationship is through the Date/Time stamp, and I've checked to make sure that the values are the same.

I tried to troubleshoot by adding a join, and everything worked as expected. Obviously with Joins you can only have a 1-1 relationship as opposed to a 1-Many.

enter image description here

  • Did you ever find an answer to this? I am having the same issue. – sparky May 22 at 16:21
  • Hard to say, this was 7 years ago now... it's been a while. I did find that if I manipulate attribute tables using ArcPy you need to close the attribute table and reopen it to see the changes. That may have changed in newer versions of the software. – Roy May 23 at 11:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.