3

I need to install the full OSGeo4W64 version for 2.18.6, Windows 10, 64-bit. However, the previous release page only has the standalone QGIS installer:

http://download.osgeo.org/qgis/windows/QGIS-OSGeo4W-2.18.6-1-Setup-x86_64.exe

Where do I find the full OSGeoW64 installer for 2.18.6?

=========================================

Edit:

After following the answer from @mgri below, I get the following error when I try to run 2.18.6:

enter image description here

However, qgis_app.dll does exist, in the correct path.

I have reinstalled twice, each time using the latest full OSGeoW64 installer (which is the only installer I am aware of, and installs 2.18.7 by default). The first time I followed mgri's instructions at the initial install, requesting 2.18.6. The error ensued. The second time I installed 2.18.7, then went back and did a custom install, again following mgri's instructions, and modified the install to revert to 2.18.6. Again, the error.

After an internet search regarding "Entry Point Not Found", I ran the Windows System File Checker, but it turned up no problems.

I am still unable to install 2.18.6, looking for assistance.

4

If the standalone install works for you, and OSGEO4W64 at least installs QGIS and the GDAL FileGDB driver, you can add FileGDB support to the standalone version by copying the files

C:\OSGeo4W64\bin\gdalplugins\ogr_FileGDB.dll
C:\OSGeo4W64\bin\FileGDBAPI.dll

to the folders used by the standalone version, i.e.

C:\Program Files\QGIS 2.18\bin\gdalplugins\
C:\Program Files\QGIS 2.18\bin\

Both GDAL installations are version 2.1.3 in my case.

  • Perfect! That solved the problem. I also restarted the computer; I don't know if that was required. In retrospect, I should have mentioned that I needed the FGDB support in my OP, my apologies. If you would like to post as an answer, I will give you credit. Thanks also to @mgri. – Stu Smith May 9 '17 at 14:46
3

You may downgrade to the previous version by directly using the OSGeo4W Setup:

enter image description here

In the above image, on the left there is the currently installed version and, on the right, the previous version will be shown if you click two times on the Skip selector that will appear.

  • Thanks for your quick response. Your answer made perfect sense. I followed your instructions, and the install proceeded without error. However, when I tried to start 2.18.6, an error message appeared. I saved a screenshot, but I don't know how to insert a picture in this comment. The error was titled "Entry point not found", and it referred to C:\OSGEO4~1\apps\qgis\bin\qgis_app.dll. Any suggestions? – Stu Smith May 6 '17 at 18:04
  • @StuSmith I can edit your original question for adding more information about the issue. However, you may try to restart the system, or even to delete the .qgis2 folder (follow the suggestion in this post). – mgri May 6 '17 at 18:26
  • Does it help if you install into a different folder? – AndreJ May 7 '17 at 5:53
  • @StuSmith What about the suggestion by @AndreJ? – mgri May 8 '17 at 8:03
  • Unfortunately, the same problem exists with the answer from @AndreJ – Stu Smith May 9 '17 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.