I am visualizing a .kmz in google earth and when a point is clicked one can read the attributes, such as lat/long, name, etc.

However, when I open the same file in QGIS the point display, BUT all attributes in the attribute table show as "null", and the original attribute categories are missing.

How can make the attribute table show correctly in QGIS?

in google earth

in qgis

2 Answers 2


The custom content that you see in Google Earth is saved in one field called description. Indeed in the QGIS screen shot, we can see that this field starts with the same content as displayed in GE (Unknown Point Feature).

You could display this field as map tip, especially if it is formatted!

Another option would be to save as another format, add new fields then populate them using the description field.


I managed to solve it differently, perhaps not in the most pro way but it worked for my purposes. Here is how:

  1. Inside Google Earth, I right clicked the parent file that contained all the points and hit "copy".
  2. I pasted it into a new excel spreadsheet
  3. I edited the spreadsheet as it contained lots of useless stuff (looked like code residues from GE). This took about 45, probably because I am not yet super skillful. I had to be real careful not to lose info in the process of erasing things... it happened a couple of times at first.
  4. I saved the spreadsheet as a .csv, opened it in QGIS and voilà! Now I can visualize the info in any GIS software.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.