2

I am new to QGIS and am trying to dissolve polygons in my shapefile using one of the fields in the attribute in QGIS 2.8.5. The process runs, and it does add a new map but nothing seems to have changed in the new map and the polygons chosen on the basis of the field are not merged.

If this is a known problem, how can I work around it?

6
  • 1
    My guess is this is there are either invalid geometries or topology errors. If you use the Topology Checker in QGIS to see if you get any errors.
    – lolcat
    May 7 '17 at 4:44
  • 1
    Does it work if you try to dissolve all?
    – underdark
    May 7 '17 at 9:57
  • I tried geometry validity check and it threw no errors. I also tried changing projection to PCS from GCS as someone had suggested on a forum. Again, nothing. As for dissolve all, once it went through and nothing showed up. The other time, it just hung. Am I missing something perhaps in my installation?
    – R Sharada
    May 7 '17 at 17:05
  • What is the CRS of your data and what is the CRS of your project? May 8 '17 at 6:15
  • could you provide your shapefile? May 8 '17 at 11:59
1

Try to run V.clean toolbox (snap, break) before running "dissolve". It worked for me

0

Convert the shapefile to .kml layer first then use dissolve. After dissolve, you can then convert the kml layer back to shp. Worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.