I had the .tif file and by using "Layer to kml" toolbox (without changing the preset parameters) i got the kmz file with very bad resolution. Then i tried to modify it changing the values for output image properties. But the results is strange, instead of having the same cell size i got this weird shifted/overlapped pixels. Scale and all other parameters stayed the same, only the output image properties that were changed..

Have you ever met this problem?

this is the original tif file converted into kmz

  • What were the precise steps that you performed (tools and parameter values) to see this?
    – PolyGeo
    May 8, 2017 at 11:02
  • Please use the edit button beneath your question to revise it with any requested clarifications.
    – PolyGeo
    May 8, 2017 at 11:42

1 Answer 1


Yes this does happen, unfortunately... you can try to minimize the change of cell values by;

  1. Project your original raster layer to WGS84 beforehand. (At least this gives you a chance to choose interpolation method fit for your purpose). Do not leave projection process to this tool.
  2. Layer To KML has Output Image Properties. This allows you to specify the Size of returned image (pixels). Use a multiple of your raster size (columns or rows).
  3. Setting higher DPI may also help (i have not tried).

Still, we cannot have much hope for a perfect translation to KML.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.