1

Using geoserver 2.9.2. I'm generating vector-tiles (geojson output, EPSG:27700) for the full extent of a layer, for only one zoom level. Estimated number of tiles is around 17.000.000. After full generation, when I can see that each job has completed, let's say, 2125000 tiles, on disk I have only around 1.000.000 files.

the disk quota is set at 10 GiB, and the total size of tiles cache is 4.5 GiB.

I tried to use only one thread... same result: the tiles completed displayed by GWC interface is different by the number of files on disk.

In OL, when I hit the missing tile, and on the request header I can see the MISS, on disk, the missing file is generated.

The geoserver is running in a docker container, with cachedir mapped on a NAS. (I tried also on a fresh installed geoserver (not using a docker container)

Somebody know what is with this difference between GWC completed tiles and actual files on disk?

note1: if for a given extent is generating 16 PNG files, for the same extent is generating only 1 geojson file.

The ratio between PNG generated files and GEOJSON generated files is 16:1, which makes sense: for ~17.000.000 estimated tiles to generate ~1.000.000 files. The rest of vector tiles are missing, and when I request a missed one, the header is marked as MISS and is generated on disk.

  • I tried to reseed for a smaller area. In logs I can find: <br> 2017-05-09 09:53:21,453 INFO [seed.SeedTask] - GWC Seeder Thread-12 completed (re)seeding layer OS:TOPOGRAPHICLINE_CACHE after 1360 tiles and 4 seconds. 2017-05-09 09:53:21,453 INFO [seed.GWCTask] - Thread group finished SEED task after 4.907 seconds <br> but on disk, 0 tiles generated. I get tiles generated If I use the entire extent of the layer, bot less then 10% from the tiles – Stefan Simon May 9 '17 at 9:12
2

a team member found the issue.

For geojson tiles seed, you need to set on the layer Metatiling factors to 1x1 instead the default 4x4, otherwise GWC will consider that already generated 16 tiles.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.