I have a Wayne county Michigan parcel dataset with a custom SRID: when I bring it into ArcGIS

Projected Coordinate System:    NAD_1983_HARN_StatePlane_Michigan_South_FIPS_2113_Feet_Intl
Projection: Lambert_Conformal_Conic
False_Easting:  13123359.58005249
False_Northing: 0.00000000
Central_Meridian:   -84.36666667
Standard_Parallel_1:    42.10000000
Standard_Parallel_2:    43.66666667
Latitude_Of_Origin: 41.50000000
Linear Unit:    Foot

Geographic Coordinate System:   GCS_North_American_1983_HARN
Datum:  D_North_American_1983_HARN
Prime Meridian:     Greenwich
Angular Unit:   Degree

I am trying to insert this SRID into PostGIS. Is this enough info to go and create the insert statement into PostgreSQL?

2 Answers 2


It's easy here

  1. Look it up on http://www.spatialreference.org
  2. Find it SR-ORG:7069 NAD_1983_HARN_StatePlane_Michigan_South_FIPS_2113_IntlFeet
  3. Click PostGIS spatial_ref_sys INSERT statement
  4. Run that insert command.

Reproduced below,

INSERT into spatial_ref_sys (srid, auth_name, auth_srid, proj4text, srtext)
values ( 97069, 'sr-org', 7069, '', 'PROJCS["NAD_1983_HARN_StatePlane_Michigan_South_FIPS_2113_IntlFeet",GEOGCS["GCS_North_American_1983_HARN",DATUM["D_North_American_1983_HARN",SPHEROID["GRS_1980",6378137.0,298.257222101]],PRIMEM["Greenwich",0.0],UNIT["Degree",0.0174532925199433]],PROJECTION["Lambert_Conformal_Conic"],PARAMETER["False_Easting",13123359.58005249],PARAMETER["False_Northing",0.0],PARAMETER["Central_Meridian",-84.36666666666666],PARAMETER["Standard_Parallel_1",42.1],PARAMETER["Standard_Parallel_2",43.66666666666666],PARAMETER["Latitude_Of_Origin",41.5],UNIT["Foot",0.3048]]');

Now you have SRID 7069.

  • 1
    ahh gotcha that worked, I initially could not find it, thanks
    – ziggy
    May 10, 2017 at 1:27
  • Evan, I am looking for a guide on how to decipher the proj4text and the srtext for SRID's so I can better understand what goes into constructing a SRID. do you have any good resources, I have not found any good documentation
    – ziggy
    May 10, 2017 at 3:27
  • 1
    The official documentation for proj.4 is all I have to point you to. proj4.org It's not easy. There are a thousand ways to project coordinates and proj.4 supports them all (afaik). Search for [ in the above insert. All of those things you see are text arguments. The syntax is simple. The command itself is incredibly complex. May 10, 2017 at 3:44
  • Try to find a copy of ISO 19162--there should be a similar document available at OGC. While very few people have implemented this version of CRS WKT, it'll have references to the previous versions.
    – mkennedy
    May 10, 2017 at 18:17
  • a zero-length proj4text string in this answer will not work with PostGIS.
    – Mike T
    May 12, 2017 at 6:03

TL;DR: use INSERT statements from http://epsg.io/ instead of http://www.spatialreference

I just came accross this question as I was looking for how do one inserts a new projection into the spatial_ref_sys table of Postgis. I tried the tip in the approved answer in PostgreSQL 9.5.15 with a 6 numbers-long SRID, but it failed as shown below (I replaced the real values with for brievity):

the code:

=# INSERT into spatial_ref_sys (srid, auth_name, auth_srid, proj4text, srtext)
values ( 9<the-srid> <the-auth>, <the-srid>, <the-proj4-text>, <the-sr-text>);

the error:

ERROR:  new row for relation "spatial_ref_sys" violates check constraint "spatial_ref_sys_srid_check"
DETAIL:  Failing row contains <the-row>

I looked into the schema of the spatial_ref_sys table:

=# \d spatial_ref_sys
     Table "public.spatial_ref_sys"
  Column   |          Type           | Modifiers 
 srid      | integer                 | not null
 auth_name | character varying(256)  | 
 auth_srid | integer                 | 
 srtext    | character varying(2048) | 
 proj4text | character varying(2048) | 
    "spatial_ref_sys_pkey" PRIMARY KEY, btree (srid)
Check constraints:
    "spatial_ref_sys_srid_check" CHECK (srid > 0 AND srid <= 998999)

It clearly shows the SRID values in this table must be 6 numbers-long at most, which is broken by the "9" that is added in front of the srid in the SQL INSERT statements provided by http://www.spatialreference. However, the same statement given by http://epsg.io/ does not have this flaw. Therefore, you are better off using this website instead of the other one.

  • Is this CRS not just the same as EPSG:2898? At least GDAL 2.3.2 has it.
    – AndreJ
    Dec 13, 2018 at 9:44
  • Yes I've caught this problem with the extra 9. I always have to remove it b4 inserting
    – ziggy
    Dec 13, 2018 at 14:17
  • @AndreJ, it was not an EPSG code at all, but an ESRI one. And I was unable to find an equivalent in EPSG namespace
    – Oyono
    Dec 13, 2018 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.