0

I am trying to overlap an UTF grid on a WMS layer in order to interact with it. As front end library I am using leaflet and the layers are served by GeoServer.

Now, I found some Leaflet plugins that are able to handle the UTFGrids, the problem is that they accept as input an URL formatted in this way:

http:///layer/z/x/y.json

Is there a way to get my UTF grid using this template?

1

I did not try, but you should be able to use the internal GeoWebCache TMS service, even without actual caching, by setting:

  • metatiling factor to 1
  • disable caching on all zoom level (but the first one, there is no way to disable it for all zoom levels)
  • "caching" only in UTFGRID format
| improve this answer | |
  • Hi thank you for your answer. I tried your solution. The problem is that I get this kind of answer from geoserver: Coverage [minx,miny,maxx,maxy] is [271, 191, 272, 191, 8], index [x,y,z] is [132, 91, 8] The url that I am using is the following: http:/server_address/geoserver/gwc/service/tms/1.0.0/layer_name@EPSG:4326@application/json;type=utfgrid/8/132/91.json And the HTTP answer that I get is 404 – Andrea Ialenti May 13 '17 at 10:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.