I have read all the questions on the SIP module and QGIS, but they do not answer my question. Most of these are dealing with screwed up paths; I do not think my environment variables are incorrect.
I've got a Windows 7 x64 system running Boundless Desktop 1.0 (QGIS 2.14 Essen). I set its python install to be the primary system python, and have been pip-ing a bunch of libraries I need. Here are my user environment variables:
GDAL_DATA = C:\Boundless\osgeo4w\share\gdal GDAL_DRIVER_PATH = C:\Boundless\osgeo4w\bin PATH = [path variables],C:\Boundless\osgeo4w\bin;C:\Boundless\osgeo4w\apps\qgis\bin;C:\Boundless\osgeo4w\apps\Python27\Scripts PYTHONHOME = C:\Boundless\osgeo4w\apps\Python27 PYTHONPATH = C:\Boundless\osgeo4w\apps\Python27;C:\Boundless\osgeo4w\apps\Python27\Scripts;C:\Boundless\osgeo4w\apps\Python27\DLLs;C:\Boundless\osgeo4w\apps\Python27\Lib
When I start QGIS, I am faced with this:
RuntimeError: the sip module implements API v11.0 to v11.3 but the qgis._core module requires API v10.0
When I check sip within a python shell, I get the following:
>>>import sip >>>print(sip, sip.SIP_VERSION_STR) (module 'sip' from 'C:\Boundless\osgeo4w\apps\Python27\lib\site-packages\sip.pyd'>, '4.18.1')
When I check sip from the command line, I get the following:
C:\>sip -V 4.14.7
So I've got a mismatch between two versions of sip. The QGIS error indicates that it is looking for an older version.
I have, since installing and configuring QGIS, updated GDAL (to 2.1.3) and PyQt4 (to 4.8.6). My feeling is that these actions have broken QGIS, and my question is this:
Is there a particular version of GDAL/PyQt4 I can just downgrade to, or would the better option be to reinstall QGIS, thereby (hopefully) overwriting and replacing the offending libraries?