3

I'm trying to model the great lakes bathymetric data for a cnc. I'm using Qgis to handle the conversion

The Geotiff was obtained from https://www.ngdc.noaa.gov/mgg/greatlakes/erie.html

using the raster calculator I removed the elevation above 0 ("erie@1" <= 0)*"erie@1"

which gave me Land elevation removed

I've tried using DEMto3d plugin to generate the stl file, but I can't get it to look like the raster in qgis

I have tried increasing the exaggeration factor in the plugin (demto3d) to 10 and even used the raster calculator to exaggerate the the raster file before converting. "erie@1"*100

Any suggestions?

  • i can't seem to get a model (it crashes qgis, but I know this plugin DOES work if you get the settings just right). Have you tried reducing the vertical exaggeration (using raster calc) a lot? Also, you tried the invert terrain option? Also, there are several formats available (e.g. floating point, integer), have you tried one of the other formats? – Steven Kay May 10 '17 at 19:24
  • also, if you did manage to produce an stl, can you add a screenshot of what it looks like as a mesh (e.g. from blender or meshlab)? – Steven Kay May 10 '17 at 21:02
  • 1
    I previously answered a question related to STL and DEMto3D plugin here: gis.stackexchange.com/a/229242/63384. Check the settings based on this link according to your case, and I hope it can help you solve the issue. – ahmadhanb May 11 '17 at 0:56
1

Appreciate the help. I played withe settings in DEMto3D. I was able to get my desired effect. It turned out to be a post qgis error on my part. I was reducing all 3 axis by the same percentages in my CAD software.

After making my z independent, I retained the detail. I also ended up using raster calc to exaggerate the original data by erie1@1*300 and another exaggeration factor of 5 in the DEMto3D

enter image description here.

| improve this answer | |
  • user3049898, did you need to convert all values to positive before the conversion to STL in DEMto3D (i.e., the lowest point in your bathymetry is 0 and the flat area around the lake is in effect an elevated plateau)? I had read that the plugin requires positive values. – Dan Jun 20 '19 at 18:03
  • I found that's best to set the lowest point at 1. It just makes it easier when manipulating it in your cad software. – user3049898 Jun 25 '19 at 0:02
  • Thank you for the tip, will give that a try. – Dan Jun 25 '19 at 0:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.