I am an ArcGis 10. ( ArcEditor licence) user and I have a problem when trying to load data with the Load Objects Tool in ArcMap.

I want to load a table, but after I choose the input data (equipment.dbf) - Add- and press next , ArcMap instantly shuts down and the well known window appears:

ArcGis Desktop has encountered a serious application error and is unable to continue.

One more thing, I am trying to load the table into a file geodatabase with a geometric network and relationship classes (but that shouldn't be a problem as support says).

Does anyone know why, and what is the solution?

  • Does it happen with all .dbf files, or just with equipment.dbf? Does it happen when loading into an empty file geodatabase? Apr 23, 2012 at 13:06
  • 1
    check that there are no special characters in the field names.
    – Brad Nesom
    Apr 23, 2012 at 13:27

2 Answers 2


It's very hard to tell without seeing the 'equipment.dbf' file, but my guess is that there is something about the data file that Arc doesn't like. I wonder if there is something about the DBF schema that is unusual/unexpected (since it is failing at the schema test). In addition to Kirk's question, have a look at:

  1. Do the field names conform to a strict interpretation of the dbf spec (no commas or other 'odd' characters and not longer than about 12 characters)?
  2. Does this file open with Excel? If so, then the file itself is probably not corrupt. If no, your file is corrupt in some way.
  3. Can you load the file into the table of contents? If 'yes' to '2' but 'no' to '3', then the file contains some non-conformance but isn't corrupt.
  4. Do you get the same problem if you try using the ArcCatalog Simple Loader (I would expect so).

Work-around suggestions: If you can't spot anything wrong with the dbf file, can you import it as XY data, convert to a shapefile and then use that (perhaps with a Union on your target file or through the loader)?

  • +1 does it open in excel?
    – Roy
    Apr 23, 2012 at 16:06
  • Hello Sylvestener:P First of all I would like to thank you for helping me again. Now, what I've got: 1.checked the files again, no comma, 8 characters, just letters- still no. 2. opened it with an excel, it worked -still no. 3. load it in the table of contents, visualize it - but still no. 4. tried to load it in ArcCatalog, and I get the message "Cannot load into non simple data". Have no idea. Does it matter if i'm trying to load a dbf. in a file geodatabase table? Isn't it possible? 10x again
    – Ligia
    Apr 25, 2012 at 7:55
  • It is NOT just because you are trying to load a DBF in a file-based geodatabase. It ought to work. The only clue we have here is the error from ArcCatalog. Are you trying to load into a feature class or a table? Can you try one more test: can you load your dbf into an new empty table (set up a test-table with a couple of fields). If so, we can be sure the dbf is OK and switch our attention. Apr 25, 2012 at 9:15
  • I'm loading in a File Geodatabase table. So from table to table. Tried your new test :P guess what? It didn't worked:))) ÄrcGIs has ecountered a serious application error and is unable to continue...bla bla bla...please tell esri about this problem:P...I DID.. contacted ESRI Romania..they didn't know either:P
    – Ligia
    Apr 25, 2012 at 10:30
  • OK I'm clutching at straws now, but do you have the latest service pack? I'm using Arc 10 SP 3 and don't have this problem. Apr 25, 2012 at 10:47

According to an ESRI Product Engineer, you cannot load table to table with Load Objects in ArcMap, the only possibility is using Simple Data Loader in ArcCatalog. But of course in this case you cannot have relationship classes, geometric network interfering. Unfortunately he is right.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.