2

I am having trouble exporting my map that has the same quality in the inset. The lines come out blurry.

Main vs. Inset

You can see a big difference between the quality. Any ideas?

  • Are they in the same Layout view ? Do you have two data frames ? – PROBERT May 11 '17 at 20:30
  • 2 separate data frames, same layout view. – Tyler Miller May 11 '17 at 20:32
  • What kind of file did you export to ? You may need to go to PDF options and play it around until you figure it out. Do you know how to go to PDF Options ? – PROBERT May 11 '17 at 20:44
  • 4
    It looks like you're rasterizing your layers in the inset, this could mean that one of the higher (later drawing) layers has transparency set; put transparent layers below vector layers or turn transparency off. How does it look on screen? I'm assuming it looks great in ArcMap but the export is pixelated. If you can't adjust transparency up the resolution of the output image - PDF can go to 720. – Michael Stimson May 11 '17 at 21:17
  • Related to (maybe possible duplicate of) gis.stackexchange.com/questions/13699/… – fatih_dur May 12 '17 at 2:48
1

You could try running this in the python window (for both frames), just to make sure all of your transparencies are off:

import arcpy

def DetectRasterization(): mxd = arcpy.mapping.MapDocument("CURRENT") df_list = arcpy.mapping.ListDataFrames(mxd) foundRasterization = False noneFoundMsg = "No rasterizing layers were detected." for df in df_list: lyr_list = arcpy.mapping.ListLayers(mxd, data_frame=df) for lyr in lyr_list: if lyr.isRasterizingLayer or lyr.supports("BRIGHTNESS"): foundRasterization = True if lyr.isGroupLayer and lyr.transparency > 0: print "In data frame '" + df.name + "', the group layer '" + \ lyr.longName + "' is a rasterizing layer:\r", print "\tVisibility is " + str(lyr.visible) + ".\n" + \ "\tTransparency is " + str(lyr.transparency) + " percent.\n" elif not lyr.isGroupLayer: print "In data frame '" + df.name + "', the layer '" + \ lyr.longName + "' is a rasterizing layer:\r", if lyr.transparency > 0: print "\tVisibility is " + str(lyr.visible) + ".\n" + \ "\tTransparency is " + str(lyr.transparency) + " percent.\n" else: print "\tVisibility is " + str(lyr.visible) + ".\n" + \ "\tTransparency is 0 percent, but the layer may be a\n" + \ "\traster layer or contain rasterizing symbology such\n" + \ "\tas bitmap picture symbols.\n" del lyr del lyr_list del df if not foundRasterization: print noneFoundMsg del df_list del mxd

DetectRasterization()

It is easy to miss a layer or two when you have a lot going on.

1

Transparent layers cause any vector layers underneath it to be rasterized in the output pdf. I can see that you have a transparent layer in both dataframes. The blue polygon at the top left of the screenshot has a pixelated border (In the main dataframe). When you zoom in (inset), the pixels of all the rasterized layers become more visible.

As @Michael Miles-Stimson said, try moving your transparent layer as far down the stack as you can. (Do those lines really need to be covered by the transparent layer? Bring them up to the top and they will export as vectors).

Here is another answer explaining transparency in ArcMap: Transparency for PDFs in Arc (Thanks @faith_dur).

  • I adjusted all of my layers and all layers in the inset are still coming out blurry. It is as if the Inset data frame is being processed completely separately at a lower resolution and being pasted on top. – Tyler Miller May 12 '17 at 11:14
  • As an experiment, will you please try this: 1. Locate all layers that have transparency enabled. 2. Turn off those layers. 3. Export the map. Is the inset still blurry? – jbalk May 15 '17 at 0:51
0

I had similar problem in ArcMap 10.6. Export to PDF became rasterised- vectors were lost. I find out that in some cases if you have group layers PDF becomes rasterised. I have simply reordered my layers all under one "root" layer and export was vectorised PDF. Hope it helps...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.