6

I installed QGIS 2.18 after i had uninstalled the version 2.16. It installed quite well but it is not starting at all. I went into the program directory and click on the exe file and got the error "The program can't start because qgis_app.dll is missing from your computer. Try reinstalling the program to fix this problem". I have installed severally and the same error keeps coming on. Any help?

  • 2
    Try running the qgis.bat file and see if it loads. You can find this in the bin folder of your QGIS directory. – Joseph May 12 '17 at 9:03
  • 2
    Maybe this will help :anitagraser.com/2016/03/26/… – Konan Pruiksma May 12 '17 at 10:52
  • 1
    Thank you for your response. I have tried it and yet it is still returning the same erorr when I tried to associate the project file with the qgis.bat file. Perhaps there is a programme blocking the programe from working. – John May 13 '17 at 13:16
  • Same problem here... Looking forward for an answer! – TurboGraphxBeige Jul 10 '17 at 17:36
  • I avoided the problem by installing 2.18.10 instead of 2.18.9 – TurboGraphxBeige Jul 10 '17 at 21:00
3

I've had the same problem (missing dll files) with QGIS 2.14 LTR and I reinstalled several times. Opening QGIS with the bat file did not work.

My problem has been solved by uninstalling and searching for all "qgis" files (not the project files) on the C-drive and delete them (also temporary files).

After that and a fresh install of QGIS 2.14 LTR, it works!

1

I had this problem on an upgraded Win machine just now and the file to redirect to - for 2.14.1x at least is qgis-ltr.bat. All shortcuts / aliases should point to this.

1

Same problem. Go to C:\Program Files\QGIS 2.18\bin, copy qgis.bat.tmpl, and rename it to qgis.bat, open it. That's it!

0

I got this error with windows when I didn't install as administrator, reinstalling with elevated permissions solved it for me. To install as admin, right click on the installer exe and click 'run as administrator'.

  • In my experience, I saw some folder access blocking activities, shown by the computer defender, during the installation. What I did was to turn of the folder protection during the offline QGIS installation. The other wise solution is to install QGIS from OSGeo4W bundle. Good luck. – Santosa Sandy Oct 24 at 4:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.