1

I would like to update scipy to version 0.19 as it has the nice calculate area of a convex hull method. When updating with conda, this updates fiona to version 1.7. Now I get an error trying to import fiona.

ImportError: dlopen(/Users/phil/anaconda/lib/python2.7/site-packages/fiona/ogrext.so, 2): Library not loaded: @rpath/libnetcdf.11.dylib Referenced from: /Users/phil/anaconda/lib/libgdal.20.dylib Reason: Incompatible library version: libgdal.20.dylib requires version 12.0.0 or later, but libnetcdf.11.dylib provides version 11.0.0

I have tried a number of fixes, for example here and have seen this regarding geopandas but none of these worked. Do I have to roll back to fiona 1.6 and scipy 0.18?

2

SciPy and Fiona do not depend on each other. It looks like your installation of GDAL is not working: the error states that libgdal requires version 12 or later of libnetcdf, but you have version 11 installed. As you are using Anaconda I suggest you do the following.

Uninstall scipy, fiona and gdal:

conda uninstall scipy fiona gdal libgdal

Add the conda-forge channel (more info https://conda-forge.org/):

conda config --add channels conda-forge

Reinstall the modules (GDAL will be installed automatically):

conda install scipy fiona

Unfortunately you're working in the root environment. If these steps don't work my next suggestion would be to delete and recreate you environment. As it is, you'd have to reinstall Anaconda.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.