2

I have a polygon layer representing land cover, and a layer of buffers around specific points.

Land use and buffer layer

I want to intersect the layers to later measure the proportion of each land-use in each buffer zone. However, I get an error "'NoneType' object has no attribute 'difference'"

So I assumed I had errors in my land-use layer. I used the 'check geometries' tool and created a new "test" layer covering all my buffers to see where the error could be. After a few corrections, I can now intersect my "test" layer and my "buffer" layer; my "land-use" layer and my "test" layer, but still not my "land-use" and "buffer" layer - the error is still the same.

Intersection of test and land-use

I can't find what could go wrong.


You can find my layers there

  • 1
    It seems that you have problems with some features (if this is the case, you should repair their geometries). Could you share both buffer and landuse layers? – mgri May 22 '17 at 14:36
3

I eventually solved the problem by updtating my version of QGIS (I had 2.16) to the new version (2.18).

After that I was mysteriously able to intersect my layers.

  • Well done! I wouldn't find any problems because I'm also running QGIS 2.18. – mgri May 23 '17 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.