1

I'm having some odd issues with the Near tool in ArcMap 10.4.1 using Geodesic method, no location or angle specified. The tool works, but returns near FIDs for polygons that are absolutely not the nearest. For instance, I can visually see that polygons from the input feature and near feature are adjacent, but the NEAR_FID is for a different polygon.

I've repaired geometry on all involved parties, converted multi-part to single-part for the near features, and tried a variety of search radius sizes.

5
  • 1
    Welcome to GIS SE! As a new user please take the tour to learn about our focused Q&A format. What inputs did you use in the Near tool? – Midavalo May 23 '17 at 1:05
  • Both inputs are shapefiles. – user97720 May 23 '17 at 13:51
  • Sorry I mean what values did you use for each parameter in the tool dialog – Midavalo May 23 '17 at 13:53
  • Please edit the question to add this info – Midavalo May 23 '17 at 13:53
  • Oh sorry, I misunderstood. I edited based on what I think you're asking for, I don't remember what radius sizes I used. – user97720 May 23 '17 at 15:27
3

I have seen this before, I think it was a bug (although I thought it had been fixed by 10.4, so might be different).

What we had to do was this:

  1. Select by Location, using the desired search radius
  2. Then run Near tool without a search radius.

The NEAR tool would run only on the selected records (from the Select by Location) and have the same effect as doing a Near search with a radius.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.