1

I've rendered a fairly ordinary chloropleth in QGIS (2.18) and am trying to export it to SVG via the print composer. While the text labels come through fine, the shapefile's layer is exported as an image within the SVG, rather than as paths. Why is this happening and how do I get it to export as paths?

  • Re-making the QGIS project from scratch worked, though I'd love to know how this got started in case it happens again on a project that's more difficult to remake entirely. – futuraprime May 23 '17 at 13:08
  • Sounds like your polygon/lines have too many vertices so QGIS automatically rasterises them to a raster so they would need to be generalised before exporting. – Mapperz May 23 '17 at 14:14
  • @Mapperz QGIS doesn't do that automatically. There's an option in the layer properties to force individual layers to export as rasters, but it's not on by default. – ndawson May 23 '17 at 22:49
1

Certain rendering settings will force the layer to export as a raster. Specifically, if you set a layer transparency or layer blend mode (under the "layer rendering" section) the layer will be automatically rasterised in order to match the exported svg to what's rendered inside QGIS.

  • Yeah this is right. In my experience you can usually open an SVG in inkscape or similar and select the rasterised layer and ungroup it (you may need to do this several times), deleting the raster parts until you get to the underlying shape and then re-symbolise it in the SVG. To be certain it will export ok do all of your complex rendering (e.g. transparency) in the post-GIS SVG processing stage. – Ed Rollason Aug 29 '17 at 8:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.