I have QGIS 2.18 and the option to create a New Mapset is unavailable to me. GRASS is installed but when I go to the Plug-Ins>GRASS only Open GRASS Tools and GRASS Options are available to me. These are also the only icons in the GRASS toolbar.

How can I work with GRASS?

enter image description here

Update, I also notice this ('Currently selected GRASS installation is not valid'): enter image description here

  • Which QGIS 2.18.x version are you using? Could you edit your question to include a screenshot please? An alternative could be to run the GRASS GIS 7.x.x program which somes with your QGIS, create a new mapset through that then open it in QGIS. I still have 2.18.2 but is working fine.
    – Joseph
    May 25 '17 at 13:45
  • I have added a screenshot. I'm not sure how top open GRASS directly without downloading it standalone. It doesn't seem to appear anywhere as an application? (I'm using a Mac)
    – Beardsley
    May 26 '17 at 12:44
  • 2
    Please add the solution as new answer and accept it to close this.
    – markusN
    May 28 '17 at 20:02

I fixed this by changing my Custom path to: /Applications/QGIS.app/Contents/MacOS/grass7

  • Mine was in /Applications/QGIS3.14.app/Contents/Resources/grass7 and I set it in under the tab: Plugins/GRASS/GRASS Options/Custom
    – Dave X
    Oct 16 '20 at 19:02

I too had this error with QGIS 3.6.1 on Windows 10. The exact error message was :

GRASS init error: GRASS was not found in 'D:/program files/QGIS 3.6/apps/grass/grass76/' (GISBASE), provider and plugin will not work.

I wondered if having spaces in the file path was a problem i.e. program files.

So, I copied the folder grass76 from my install location D:/program files/QGIS 3.6/apps/grass/ to D:/.

I then went back to plugins > grass > grass options and changed the custom directory to reflect the new location D:/grass76.

It worked!


I did on Windows what Mike mentioned, but instead I created a symbolic link from D:\grass78 <<===>> D:\Users\*user*\programs\QGIS 3.16.3\apps\grass\grass78

  • Thanks, solved my problem aswell!
    – Nils
    Oct 14 '21 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.