5

I need to snap out parts from a polygon. I am using the "split part" to mark the area I need to erase:

enter image description here

In order of snapping an area, I drew a line inside the polygon. Sometimes this method does not work and I receive an error message like this:

enter image description here

I tried to change the snap settings, but it did not help:

enter image description here

Can anyone help me?

  • You appear to be confusing the terms 'snap' and 'split'. They mean and do very different things. – MappaGnosis May 26 '17 at 11:17
8

With reference to the error you get, it seems that some geometries are invalid (in this case, the lake layer). You may check it by running several tools, for example the Check validity algorithm from Processing Toolbox. It will return three outputs:

  • Valid output (i.e. the layer or the features eventually valid);
  • Invalid output (i.e. the layer or the features eventually not valid);
  • Error output (i.e. a point vector layer where each point indicates a geometry issue, for example a self-intersection).

The last output is useful for quickly identifying the issues, so you can repair the geometry where needed. Once you have done this operation, the splitting operation should work.

  • I did it and get a new layer withe the same problem. – Nitzan Matan May 26 '17 at 9:49
  • Which of the three outputs listed you get? – mgri May 26 '17 at 9:53
0

I have tried a lot of things from an answers in other posts. It's look like there is a beg in the last version of Qgis. If this error is happening I just need to do the same thing other again and after some do over it will work.

However, it seems that if the snapping is not working the best way is to make the next one in a slightly different area in order to "fix" the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.