0

I'm having trouble reading fields in Chinese when importing a csv data file to ArcMap. I imported the file by using 'add data' option in the tools section. I'm confused because some csvs work while some do not, meaning for some csvs the characters are clearly read in ArcMap while for the other csv all of them are garbled.

These files were all edited in R and Python and they were encoded as utf-8. They both do not get garbled characters when read in R, so I'm not sure why ArcMap would not display them correctly.

The garbled attribute table looks like this:

enter image description here

I tried turning the csv file to xlsx format and then tried importing it in ArcMap but I could not import the file. I'm using ArcMap 10.5.

Could it also have to do with long texts like one in the image? I have long descriptions of each data points (around 500+).

  • Please edit your question to describe how you imported the csv data into ArcMap. – Midavalo May 26 '17 at 19:50
  • @Midavalo Amended. – song0089 May 27 '17 at 6:43
  • Excel toolset may help. – Kazuhito May 28 '17 at 11:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.