i've got some problems with QGIS and I do need your help..

I've got 2 point layers. Layer 1: 1700 points, Layer 2: 1704 Points.. Both are ESRI-Shapefiles

1700 Points are identical. only 4 points are different (different coordinates). Now I want to compare both Layers and create a new layer from the result, so the final layer should only have these 4 points. My problem is the following:

If i choose Layer 1 first, the result is 1700 points. If I choose Layer 2 first, the result is 1704 points.. I guess the problem is, that both layers are completely different (not a single attribute is identical).

how I can I get the correct result, based on the geo-coordinates? That should give me only 4 points output. I have to do this for around 46.000 points, so a hint for my problem would be awesome!

I hope you understand what I'm talking about, bc I'm new to QGIS and my english is not the best..

king regards,


EDIT: Field names Layer 1:

OBJECTID, FID_Hausko, nasoid, lebenszeit, lebensze_1, bundesland, ortschlues, ortschlu_1, ort, ortsteil, strassensc, strassen_1, hausnumm_1, unverschlu, infotext, xwert, ywert, aktuell, FID_Gemein, OBJECTID_1, gemeindezu, nasoid_1, id_1, lebensze_2, lebensze_3, anlass1, anlass2, schluessel, bezeichnun, gemeindeke, herkunft, herkunft_e, aktuell_1, hatgeometr

Field names Layer 2:

id, lat, lon, ags, kid, plz, ort, ortsteil, str, hnr, adz, kvz_id, apl_bez, nb, adsl, vdsl, vec, versorgt_d, knb, hh_me, hh_ibv, vzk_ist, db_ist, kabelnetz, mobilfunk_, mobilfun_1, mobilfun_2, mobilfun_3, fttb, ist_versor, hh_d_g, hh_u_g, ausbaug, exist, kein_Ausba


I think the answer is to use the Select By Location tool. Select By Location

Using the 'equals' option, you should be able to select all the matching points. Then use inverse selection to get the unique points.

Inverse Selection

Then use the save as option to create a new shapefile. Hope this helps!

  • doesn't seem to work... choosing Select by location tool gives me "0 objects selected"... here's a pic of my map.. the blue points are the different ones: img4.picload.org/image/riaciadr/al1.png – Patrick Hachmeyer May 27 '17 at 14:35
  • maybe the problem is the different EPSG? I've got the 2nd Layer file with different settings and "converted" it by "save as..".. now, both layers have the same "configuration", but maybe there are some issues with that? – Patrick Hachmeyer May 27 '17 at 14:56
  • I tried it out with a few demo points, which would be in the same CRS. Have you tried increasing the precision parameter in the select dialogue box? If the points are only slightly off, that may help. You should look at the CRS of each layer in the layer properties, as well as the QGIS project (which may have a different CRS). – Anonymous May 27 '17 at 15:07
  • CRS are identical - for all layers as well as for the project itself.. I tried to increase the precision without success... 0 precision gives me 0 objects and 0,000001 precision gives me ALL (1700) objects – Patrick Hachmeyer May 27 '17 at 15:14
  • I can't think of what the problem might be then, unless the points are slightly offset from each other. You could make a "lat" and "long" field for the other layer, and compare them. If the two layers really have identical geometry, a select by location should have worked. – Anonymous May 27 '17 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.