4

I'm on OS X El Capitan running QGIS version 2.18.2 which I installed via the Kyngchaos installers.

I'm trying to install a plugin, which requires, among other things, that Pysal needs to be installed. However, despite installing it via pip it's still not working.

It appears that QGIS uses a different interpreter, which I get, but I can't find it or figure out how to install anything to it.

  • 1
    Have you checked existing Q&A such as gis.stackexchange.com/questions/181858/… – underdark May 31 '17 at 18:17
  • 1
    Kyngchaos QGIS uses the standard Apple Python – gene May 31 '17 at 19:46
  • I looked around for something just like what you linked to, @underdark. Don't know why I didn't find that one. Worked well, thnx much. – Aidian Holder Jun 1 '17 at 6:27
3

The link to a previous question @underdark posted in her comment pointed me in the right direction.

The only thing not detailed there is the syntax needed to pick between two different python 2 interpreters (system default which QGIS uses + one installed by homebrew which is my default).

For that case, I had to enter the path to the relevant interpreter, the '-m' flag, then my pip command. In my case, the bash command was "/usr/bin/python -m pip install [module name]"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.