2

I tried to add these GeoJSON files to QGIS (2.18.9 & 2.14.15) with Add a vector layer by Protocol, GeoJSON with GUI OR Python Console:

Add a GeoJSON layer by QGIS protocol

But I get always this error: Data source not valid

Error when adding layer

What's going wrong with QGIS?

When I add the file downloaded, it's working.

  • Are you trying to add the GeoJSON layers via the interface or the Python Console? For QGIS 2.18.2, I can confirm it works when adding them through the interface as you have shown in your image, – Joseph Jun 2 '17 at 12:17
  • By the interface AND by python console. Same error :/ – jlSta Jun 2 '17 at 12:43
  • Works for me too. Are you behind a proxy? Can you download the files and add them locally from disk? – AndreJ Jun 2 '17 at 12:47
  • Yes, from the disk it works but i would like to use the protocol way to get alvays the updated version. It doesn't work for me in 2.14 and 2.18. Maybe i m behind a proxy.....checking on proxyornot.com..... I m not behind a proxy. – jlSta Jun 2 '17 at 13:17
  • Works for me in QGIS 2.18.3 – nmtoken Jun 2 '17 at 14:40
1

I had the same issue. After some troubleshooting, found out that it will work if I change our url from https to http

  • Ok, it works for the second link. But if the service is only https like the first one, it's not a complete solution? But thank you – jlSta Dec 20 '17 at 7:00
1

On NextGIS QGIS under Mac OS X the both URLs work fine. This version of NextGIS QGIS based on QGIS 2.14 LTS.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.