When I go into the expression builder under the "Field and Values" drop down on the left side, instead of a list of field for the layer all it says is NULL. Is there something that would cause this instead of a list of fields?

  • You might mention what version of QGIS you are using, and also what kind of layer you are running the expression on. I recall in the past that I would get nulls if I was using a file geodatabase feature class, but version 2.18.9 seems to be working just fine. – johns Jun 5 '17 at 16:51
  • That would help, I'm using the newest version. 2.18.9 I believe. I'm trying to use it on a shapefile. I tried on an original and resaving it to another shapefile. I then tried on a completely separate shapefile in a new document as well but had the same result. – Aurust Jun 5 '17 at 17:26
  • I just tested mine with a shapefile and it worked, although I noticed a new "field" in the list called Null, which when clicked gave me information on how to do a query with nulls in the right panel. That is odd but it doesn't affect any work. If you are using the osgeo4w installer advanced install, you might run that again and see if it fixes things. The current one is 2.18.9-1. – johns Jun 5 '17 at 19:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.