2

I'm making a geological map with the use of SpatialLite points, lines and polygons, but suddenly QGIS showed all kind of errors and decided it doesn't want to load my maps and SpatialLite layers any more. It happened when I clicked on a map layer to turn it on.

This is what it says:

TypeError: arguments did not match any overloaded call: QSize(): too many arguments QSize(int, int): argument 1 has unexpected type 'long' QSize(QSize): argument 1 has unexpected type 'long' Traceback (most recent call last): File "C:/Users/kikid/.qgis2/python/plugins\openlayers_plugin\openlayers_layer.py", line 125, in request self.setup_map() File "C:/Users/kikid/.qgis2/python/plugins\openlayers_plugin\openlayers_layer.py", line 201, in setup_map olSize = QSize(int(olWidth), int(olHeight)) TypeError: arguments did not match any overloaded call: QSize(): too many arguments
QSize(int, int): argument 1 has unexpected type 'long' QSize(QSize): argument 1 has unexpected type 'long'

Python versie: 2.7.5 (default, May 15 2013, 22:44:16) [MSC v.1500 64 bit (AMD64)] QGIS versie: 2.18.6 Las Palmas, 5f369b0

Python pad: C:/PROGRA~1/QGIS2~1.18/apps/qgis/./python/plugins\processing C:/PROGRA~1/QGIS2~1.18/apps/qgis/./python C:/Users/kikid/.qgis2/python C:/Users/kikid/.qgis2/python/plugins C:/PROGRA~1/QGIS2~1.18/apps/qgis/./python/plugins C:\PROGRA~1\QGIS2~1.18\bin\python27.zip C:\PROGRA~1\QGIS2~1.18\apps\Python27\DLLs C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\plat-win C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\lib-tk C:\PROGRA~1\QGIS2~1.18\bin C:\PROGRA~1\QGIS2~1.18\apps\Python27 C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\PIL C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\jinja2-2.7.2-py2.7.egg C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\markupsafe-0.23-py2.7-win-amd64.egg C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\win32 C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\win32\lib C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\Pythonwin C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\Shapely-1.2.18-py2.7-win-amd64.egg C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\wx-2.8-msw-unicode C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\xlrd-0.9.2-py2.7.egg C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\xlwt-0.7.5-py2.7.egg C:/Users/kikid/.qgis2//python C:/Users/kikid/Desktop/Kiki BSc

I tried to load my SpatialLite layers in a different QGIS map and that worked, it only didn't contain all data and colours I gave it, so it will be a loooot of work to fix that all.

Is there any way to get rid of this error?

  • 1
    Have you tried uninstalling the open layers plugin, it looks like this is what is causing the issue – Liam G Jun 8 '17 at 12:02
  • No, I just tried and it worked!! Thank you so much, you made my day! – Chello-Chellos Jun 8 '17 at 12:22
  • @Freight_Train Please post your comment as an answer so this thread can be marked as solved – underdark Jun 8 '17 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.