0

I am trying to connect to the following WFS using QGIS:

http://mapservices.prorail.nl/arcgis/rest/services/Basis_topografie_002/FeatureServer

However this gives me the following QGIS error:

Capabilities document is not valid

error occurred while parsing reference

I am using QGIS version 2.14

Is my URL wrong? I do get information if I open this in my browser.

3
  • 2
    ArcGIS REST is not WFS. Perhaps geodata.nationaalgeoregister.nl/spoorwegen/… or similar might help.
    – BradHards
    Commented Jun 8, 2017 at 11:16
  • Thanks for your response, I found a guide for connecting to ArcGIS rest using a higher version of QGIS. trying that now... Commented Jun 8, 2017 at 11:21
  • QGIS 2.18 crashes when I try to open it as ArcGIS FeatureService layer... this is getting so far off-topic I will start a new question Commented Jun 8, 2017 at 13:07

1 Answer 1

3

Is my URL wrong? I do get information if I open this in my browser.

Well your URL isn't the endpoint for a WFS. You should be able to append the following parameters (service=WFS&request=GetCapabilities&) and get a GetCapabilities response (an XML document) but you don't, see:

http://mapservices.prorail.nl/arcgis/rest/services/Basis_topografie_002/FeatureServer?service=WFS&request=GetCapabilities&

2
  • Thanks for your answer, turns out this is indeed not a WFS endpoint, but an ArcGIS FeatureServer endpoint. QGIS is still struggling with this Commented Jun 8, 2017 at 13:13
  • That's why it's better to use standards
    – nmtoken
    Commented Jun 8, 2017 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.